Userzoom down

Incident Report for UserZoom

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 19:32 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 22, 2026 - 19:09 UTC

Monitoring

UZ appears to be back up but we are still monitoring
Posted Apr 22, 2026 - 19:08 UTC

Investigating

Currently Userzoom appears to be down. We are investigating. Thank you for your patience.
Posted Apr 22, 2026 - 18:47 UTC
This incident affected: Manage (Login, User Management, Templates, Study Builder).