Degraded Performance - Accessing Studies

Incident Report for UserZoom

Resolved

The incident has been resolved. Thanks for your patience.
Posted Jul 24, 2023 - 15:34 UTC

Monitoring

A solution has been applied and now studies are now able to be loaded as expected. Apologies for the inconvenience!
Posted Jul 24, 2023 - 15:17 UTC

Investigating

Region: US
We’ve received reports that the Monitor Page is not loading correctly for some studies. Our engineering team is actively investigating.
Posted Jul 24, 2023 - 15:10 UTC
This incident affected: Manage (Study Builder).